Archive for March 2011

Courion Tip – Server 2008 and Courion 7.70 & 7.80

I spent some time setting up a new server – Windows Server 2008r2, 64 bit, 12 gig of RAM – so I could migrate our Courion installation onto better hardware, and a 64 bit OS.

Well, I had some issues with importing the workflows, and got that worked out. Then I tried to open one of the workflows I had imported. NOTHING. You cannot open it.

So, I did some searches at the Courion support site, and found that it’s NOT supported.

I will have to upgrade our systems from Courion 7.70 to 7.80, then try to migrate it onto the new server.

DARN

====================

Update.  On the Server 2008 r2, I updated to Courion 7.80 fixpack 20. On the old server, I upgraded to the same level. Somewhere along the way, the old server “broke” – I mean that the password workflows don’t function properly. However, now I am able to export the workflows successfully from the old server to the new server – and they work JUST FINE on the new server. Saved a lot of work with the new export modes that are there.

Posted March 26, 2011 by mmdmurphy in Courion Tip

Tagged with

PlugApps – Cherokee web server

http://plugapps.com/index.php5/Application:Cherokee

To install Cherokee and the cherokee-admin web interface, run:

pacman -Sy cherokee rrdtool python

You’ll probably also want PHP.

pacman -Sy php

Configuration Web Interface

Start the Cherokee Admin tool by running:

cherokee-admin -b -x

This will turn on the web interface temporally (until you press CTRL-C in SSH), which listens for connections from any computer, and outputs any error messages to SSH. You can run the web interface in the background by putting an “&” after the above command.

Running it will give you a one-time password. Copy it and paste it into http://your.plugs.ip.addr:9090, using the “admin” username.

 


Doesnt work & re-installing python doesn’t work. Possible version conflict?

[root@Plugbox ~]# cherokee-admin -b -x
env: python2: No such file or directory

ERROR: Couldn’t find python.

pacman -Sy python2 <- seems to fix it.

Running Cherokee

You can control Cherokee using cherokee-admin as mentioned above, or use “/etc/rc.d/cherokee start|restart|stop”.

To start Cherokee on boot, add “cherokee” to the DAEMONs line in /etc/rc.conf.

Posted March 7, 2011 by mmdmurphy in Uncategorized

PlugApps – Time & ntp

pacman -Sy ntp

ntpdate time.nrc.ca time.apple.com time.windows.com

That took care of it.

Posted March 7, 2011 by mmdmurphy in Uncategorized

PlugApps – Xserver

I don’t have it working yet, but to install the x window server, just type in

pacman -Sy xorg-server

Now all I have to do is figure out how to start it up!

[root@Plugbox etc]# Xorg

X.Org X Server 1.9.4
Release Date: 2011-02-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37 armv5tel
Current Operating System: Linux Plugbox 2.6.37 #1 PREEMPT Tue Feb 22 17:29:57 MST 2011 armv5tel
Kernel command line: console=ttyS0,115200 root=/dev/sda1 rootdelay=10 rootfstype=ext2 mtdparts=orion_nand:1M(u-boot),4M(uImage),32M(rootfs),-(data)
Build Date: 06 February 2011  11:53:55AM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sun Mar  6 18:22:38 2011
(==) Using config directory: “/etc/X11/xorg.conf.d”
Primary device is not PCI
(EE) Failed to load module “fbdev” (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at “/var/log/Xorg.0.log” for additional information.

Posted March 7, 2011 by mmdmurphy in Uncategorized

PlugApps – miniDLNA

Sorry about the incomplete document, but basically if you follow their instructions, you will get an error message.

Read that error message. You need to install something like “jack” – dont remember exact name.

pacman -Sy jack

 

Posted March 7, 2011 by mmdmurphy in Uncategorized